jQuery: Validação plugin de quebra quando se muda de jQuery 1.2.6 para 1.3.2

votos
1

Eu recentemente atualizado do jQuery 1.2.6 para 1.3.2

Agora, a página que eu estou usando o plugin de validação de formulário recebo a exceção:

[Exception... 'Syntax error, unrecognized expression: [@for='registration_primary_email']' when calling method: [nsIDOMEventListener::handleEvent]  nsresult: 0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)  location: <unknown>  data: no]

Isso não acontece com 1.2.6. Alguma idéia do que está acontecendo?

Publicado 19/05/2009 em 17:29
fonte usuário
Em outras línguas...                            


1 respostas

votos
7

O @seletor é depreciado em jQuery 1.3.

Tente removê-lo:

[for='registration_primary_email']
Respondeu 19/05/2009 em 17:32
fonte usuário

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more