Erros de um projeto .NET 3.5 aparecer como NET 2.x

votos
0

Enquanto meu projeto ASP.NET usa a versão 3.5 do framework , o log de eventos registra erros como vindo de versão 2.x do quadro como este:

Event Type:         Error
Event Source:       ASP.NET 2.0.50727.0
Event Category:     None
Event ID:           1334
Date:               2009-05-19
Time:               17:04:29
User:               N/A
Computer:           XXXXXXXXXX

Description:
An unhandled exception occurred and the process was terminated.

Application ID: /LM/W3SVC/234989001/Root
Process ID: 8912
Exception: System.Web.HttpException
Message: The remote host closed the connection. The error code is 0x80072746.
Publicado 19/05/2009 em 16:28
fonte usuário
Em outras línguas...                            


3 respostas

votos
14

NET 2,0, 3,0 e 3,5 são todas baseadas no CLR 2.0. A versão que você vê é a versão CLR, não a versão Framework, então está tudo bem.

Respondeu 19/05/2009 em 16:30
fonte usuário

votos
1

Para mais informações, eu encontrei este post por Scott Hanselman informativo:

Como configurar uma aplicação do IIS ou AppPool para usar ASP.NET 3.5 em vez de 2.0

Respondeu 19/05/2009 em 18:10
fonte usuário

votos
1

ASP.NET tem um número de versão diferente para o framework .Net subjacente.

ASP.NET 2.0.50727.0 lata executado com Net 3.5 - sua mensagem de erro está relatando a versão correta.

Respondeu 19/05/2009 em 16:30
fonte usuário

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more