Obtendo Subclipse no Aptana para trabalhar com a versão mais recente do Subversion

votos
34

A versão do Subclipse (1.2.4) atualmente disponível através automática do Aptana Gestor de Plugins não funciona com a nova versão do Subversion.

Vejo no site Subclipse no entanto, que eles têm 1.4.2 para fora para Eclipse. Então eu adicionei um novo site de atualização remoto para o meu gerente Update. Quando eu tentei instalá-lo, ele me disse que eu precisava Mylyn 3.0.0 . Então, depois de muita procura eu encontrei Mylyn 3.0.0 e acrescentou um novo site de atualização remota ao meu gerenciador de atualização. Então, quando eu tentei instalar isso, ele me disse que eu precisava org.eclipse.ui 3.3.0 ou equivalente.

Olhando para os detalhes de configuração para Aptana, parece que ele é construído contra o eclipse 3.2.2.

Alguém sabe se existe uma maneira de atualizar a versão do Eclipse Aptana que é construído contra a 3.3.0? Ou se há alguma outra forma de obter Subclipse para trabalhar com o muito mais nova versão do Subversion?

Eu sei que isso não é necessariamente uma questão programação, mas eu espero que seja ok uma vez que é altamente relevante para a experiência de programação.

Publicado 01/08/2008 em 14:56
fonte usuário
Em outras línguas...                            


4 respostas

votos
16

não Subclipse não exigem Mylyn, mas o site de atualização inclui um plug-in que integra Mylyn e Subclipse. Este é destinado a pessoas que usam Mylyn. No seu caso, você iria querer apenas de-select Mylyn no diálogo de atualização.

Subclipse também requer Subversion 1,5 e a versão correspondente das bibliotecas nativas JavaHL. Eu escrevi o início de uma FAQ para ajudar as pessoas a entender JavaHL e como obtê-lo. Veja: http://desktop-eclipse.open.collab.net/wiki/JavaHL

Respondeu 15/09/2008 em 14:26
fonte usuário

votos
6

Eu tive problemas com JavaHL em Eclipse Ganymede, quando ele trabalhou bem em Eclipse Europa. Eu não tenho certeza de como Aptana é diferente, mas tente quer atualizar JavaHL ou a mudança para a implementação SVNKit puro-java dentro da configuração Subclipse.

Respondeu 01/08/2008 em 15:41
fonte usuário

votos
4

se você não vai estar usando mylyn basta desmarcar essa dependência. Eu não sou muito familiarizado com Aptana, mas em eclipse você pode expandir o que está sendo instalado e desmarque qualquer coisa que você não precisa.

Respondeu 29/08/2008 em 00:47
fonte usuário

votos
3

Eu usei o URL de atualização e eu instalei o adaptador JavaHL, o próprio projeto Subclipse e o BETA adaptador SVNKit.

Após isso, funcionou bem para mim, isto é para espero plataforma linux ele funciona para você.

Respondeu 26/08/2008 em 14:41
fonte usuário

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more