Força Internet Explorer para usar um Java Runtime Environment específico instalar?

votos
43

Ao visualizar página de outra pessoa contendo um applet, como posso forçar o Internet Explorer 6.0 para usar aa JRE particular, quando eu tenho vários instalado?

Publicado 16/09/2008 em 12:07
fonte usuário
Em outras línguas...                            


8 respostas

votos
72

Em primeiro lugar, desativar a versão atualmente instalada do Java. Para fazer isso, vá para o Controle Java Panel> Java> Avançado> padrão para navegadores e desmarque Microsoft Internet Explorer .

Em seguida, permitir que a versão do Java que você deseja usar em seu lugar. Para fazer isso, vá para (por exemplo) C: \ Program Files \ Java \ jre1.5.0_15 \ bin (onde jre1.5.0_15 é a versão do Java que você deseja usar), e executar javacpl.exe . Vá para Avançado> Java padrão para navegadores e verificar Microsoft Internet Explorer .

Para obter a sua versão antiga do Java volta que você precisa para reverter essas etapas.

Note-se que em versões antigas do Java, Java padrão para navegadores é chamado <applet> Suporte (mas o efeito é o mesmo).

A boa coisa sobre este método é que ele não afeta outros navegadores, e não afeta o sistema padrão JRE.

Respondeu 10/11/2008 em 12:27
fonte usuário

votos
20

Eu tenho o mesmo problema hoje e concordo com Jack Leow. Basicamente, no Windows XP, eu tinha que ir ao Painel de Controle> Java e, em seguida:

  1. guia Java
  2. Clique no botão "Ver"
  3. Ativar apenas o JRE eu quero (ie JRE 1.5.x e manter 1.6.x desativada)
  4. Restart IE
  5. página miniaplicativo carga no IE
  6. Et voila, ele está carregando a versão correta do JRE!
Respondeu 22/06/2010 em 05:49
fonte usuário

votos
4

Para a solução do lado do servidor (que sua pergunta foi originalmente ambígua sobre), esta página em sol lista uma maneira de especificar um JRE. Especificamente,

<OBJECT 
  classid="clsid:8AD9C840-044E-11D1-B3E9-00805F499D93"
  width="200" height="200">
  <PARAM name="code" value="Applet1.class">
</OBJECT>

O atributo classid identifica qual versão do Java Plug-in para usar.

A seguir é uma forma alternativa do atributo classid:

classid="clsid:CAFEEFAC-xxxx-yyyy-zzzz-ABCDEFFEDCBA"

Nesta forma, "xxxx", "aaaa", e "zzzz" são números de quatro dígitos que identificam a versão específica do Java Plug-in para ser usado.

Por exemplo, para usar Java Plug-in versão 1.5.0, você especifica:

classid="clsid:CAFEEFAC-0015-0000-0000-ABCDEFFEDCBA"
Respondeu 16/09/2008 em 12:20
fonte usuário

votos
1

Como já foi mencionado aqui para jre6 e JRE5, vou atualizar para JRE1.4:

Você vai precisar para executar o jpicpl32.exe aplicativo no diretório / bin jre da instalação do java (por exemplo, c: \ java \ jdk1.4.2_07 \ jre \ bin \ jpicpl32.exe ).

Esta é uma versão anterior do aplicativo mencionado no post de Daniel Cassidy.

Respondeu 04/10/2010 em 08:20
fonte usuário

votos
1

Eu daria todas as respostas aqui uma primeira tentativa. Mas eu queria apenas jogar o que eu faço, apenas no caso de estes não funcionam para você.

Eu tentei resolver o mesmo problema que você está tendo antes, e no final, o que eu decidi a fazer é ter apenas um JRE instalado no meu sistema em um determinado momento. Eu tenho cerca de 10 JDKs diferentes (1.3 a 1.6, e de vários fornecedores - Sun, Oracle, IBM), desde que eu precisar dele para o desenvolvimento, mas apenas um JRE autônomo.

Isso tem funcionado para mim no meu + IE 6 computador Windows 2000 em casa, assim como o meu Windows XP + computador IE múltipla no trabalho.

Respondeu 10/11/2008 em 12:48
fonte usuário

votos
0

Você pode especificar a família de JRE para ser usado. http://www.oracle.com/technetwork/java/javase/family-clsid-140615.html

Respondeu 23/10/2014 em 11:17
fonte usuário

votos
0

Utilizar a implantação Toolkit 's deployJava.js (embora isso garante uma versão mínima, em vez de uma versão específica)

Respondeu 16/09/2008 em 13:21
fonte usuário

votos
-1

Se você quer dizer quando você não é a pessoa que escreve a página da web, então você pode desativar o add-ons que você não quiser usar com as Gerenciar Complementos Opções IE tela adicionado no Windows XP SP2

Respondeu 16/09/2008 em 13:29
fonte usuário

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more