PyCharm falhou a instalação de pacotes por causa de SSL

votos
0

Eu estou usando máquina virtual Windows 7 e eu não posso adicionar ctypes. Minha máquina física corre Ubuntu ea conexão à internet é um WiFi-hotspot.

Ocorreu um erro:

Não foi possível obter URL https://pypi.org/simple/ctypes/ : Houve um problema confirmando o certificado SSL: HTTPSConnectionPool (host = 'pypi.org', port = 443): Max tentativas excedido com url: / simples / ctypes / (causada por SSLError (SSLError (1, '_ssl.c: 499: erro: 1407742E: rotinas SSL: SSL23_GET_SERVER_HELLO: TLSv1 versão alerta protocolo'),)) - pular

saída do comando:

Ctypes coleta não foi possível obter a URL https://pypi.org/simple/ctypes/ : Houve um problema confirmando o certificado SSL: HTTPSConnectionPool (host = 'pypi.org', port = 443): Max tentativas excedido com url: / simples / ctypes / (causada por SSLError (SSLError (1, '_ssl.c: 499: erro: 1407742E: rotinas SSL: SSL23_GET_SERVER_HELLO: TLSv1 versão do protocolo de alerta'),)) - pular não foi possível obter URL https: // pypi. org / simples / PIP / : Houve um problema confirmando o certificado SSL: HTTPSConnectionPool (host = 'pypi.org', port = 443): Max tentativas excedido com url: / simples / PIP / (causada por SSLError (SSLError (1 , '_ssl.c: 499: erro: 1407742E: rotinas SSL: SSL23_GET_SERVER_HELLO: TLSv1 versão alerta protocolo'),)) - pular

C:\Python27\lib\site-packages\pip-10.0.1-py2.7.egg\pip\_vendor\urllib3\util\ssl_.py:339: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
  SNIMissingWarning
C:\Python27\lib\site-packages\pip-10.0.1-py2.7.egg\pip\_vendor\urllib3\util\ssl_.py:137: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
  InsecurePlatformWarning
  Retrying (Retry(total=4, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '_ssl.c:499: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'),)': /simple/ctypes/
C:\Python27\lib\site-packages\pip-10.0.1-py2.7.egg\pip\_vendor\urllib3\util\ssl_.py:137: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
  InsecurePlatformWarning
  Retrying (Retry(total=3, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '_ssl.c:499: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'),)': /simple/ctypes/
C:\Python27\lib\site-packages\pip-10.0.1-py2.7.egg\pip\_vendor\urllib3\util\ssl_.py:137: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
  InsecurePlatformWarning
  Retrying (Retry(total=2, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '_ssl.c:499: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'),)': /simple/ctypes/
C:\Python27\lib\site-packages\pip-10.0.1-py2.7.egg\pip\_vendor\urllib3\util\ssl_.py:137: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
  InsecurePlatformWarning
  Retrying (Retry(total=1, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '_ssl.c:499: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'),)': /simple/ctypes/
C:\Python27\lib\site-packages\pip-10.0.1-py2.7.egg\pip\_vendor\urllib3\util\ssl_.py:137: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
  InsecurePlatformWarning
  Retrying (Retry(total=0, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '_ssl.c:499: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'),)': /simple/ctypes/
C:\Python27\lib\site-packages\pip-10.0.1-py2.7.egg\pip\_vendor\urllib3\util\ssl_.py:137: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
  InsecurePlatformWarning
  Could not find a version that satisfies the requirement ctypes (from versions: )
No matching distribution found for ctypes
C:\Python27\lib\site-packages\pip-10.0.1-py2.7.egg\pip\_vendor\urllib3\util\ssl_.py:137: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
  InsecurePlatformWarning
Publicado 18/12/2018 em 11:14
fonte usuário
Em outras línguas...                            


1 respostas

votos
0

Tente atualizar seus pacotes de segurança urllib eg através pip.

pip install urllib3[secure]

Isso deve guiá-lo: https://urllib3.readthedocs.io/en/latest/user-guide.html#ssl-py2

Seu urllib parece tentar acessar pypi com TLSv1. Muito provável que eles não permitem que você, anymore.

Obtenha seu toolchain atualizado e você deve ser fino.

atualizar:

Como fazer coisas com pip em janelas em diferentes versões já foi respondida aqui: Como faço para instalar pip no Windows?

Respondeu 18/12/2018 em 12:56
fonte usuário

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more