Python: nenhum módulo chamado core.exceptions

votos
2

Eu estou tentando obter o Google AppEngine para trabalhar na minha caixa de Debian e estou recebendo o seguinte erro quando tento acessar minha página:

<type 'exceptions.ImportError'>: No module named core.exceptions 

O mesmo aplicativo funciona muito bem para mim quando eu executá-lo em minha outra caixa Ubuntu, então eu sei que não é um problema com o aplicativo em si. No entanto, eu preciso fazê-lo funcionar nesta caixa Debian. Ele tinha originalmente Python 2.4, mas depois AppEngine reclamou sobre isso eu instalei os pacotes python2.5 e python2.5-dev (sem sucesso).

Eu vi neste pós Google Grupo que pode ser devido à versão do AppEngine e apenas para reinstalá-lo, mas isso não funcionou. Alguma ideia?

Edit 1: Também tentou python2.4 desinstalar e 2,5, em seguida, reinstalar o 2.5, que também não funcionou.

Edit 2: Acontece que quando eu fiz AppEngine em um projeto CVS não adicionar o diretório do núcleo para o meu projeto, então quando eu verifiquei há literalmente foi nenhum módulo chamado core.exceptions. Re-download dessa pasta resolveu o problema.

Publicado 07/09/2008 em 21:57
fonte usuário
Em outras línguas...                            


1 respostas

votos
4

core.exceptionsfaz parte de django; qual a versão do Django que você tem instalado? O AppEngine vem com a versão apropriada para qualquer versão que você tenha baixado (no diretório lib / Django). Ele pode ser instalado, indo para esse diretório e funcionandopython setup.py install

Respondeu 07/09/2008 em 22:28
fonte usuário

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more