SQL Server 2005 e 2008 na mesma máquina do desenvolvedor?

votos
20

Alguém já tentou instalar o SQL Server 2008 Developer em uma máquina que já 2005 Developer instalado?

Não tenho a certeza se eu deveria fazer isso, e eu preciso para manter 2005 nesta máquina para o futuro próximo, a fim de testar a nossa aplicação facilmente. Desde que eu às vezes precisa tomar arquivos de backup de bancos de dados e disponibilizar para outras pessoas na empresa não pode simplesmente substituir 2005, com 2008 como suspeito (mas não sei) que os bancos de dados não são 100% compatíveis com versões anteriores.

Que tipo de problemas que surgem? Preciso instalar a nova versão com um nome de instância, será que funciona? Posso usar um número de porta diferente para distingui-los?

Eu encontrei esta entrada no TechNet: http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3496209&SiteID=17

Ele não diz mais do que apenas sim, você pode fazer isso e eu suspeito meio que este era factível de qualquer maneira, mas eu preciso saber se há alguma coisa que eu preciso saber antes de começar a instalação.

Alguém?

Publicado 07/08/2008 em 09:35
fonte usuário
Em outras línguas...                            


7 respostas

votos
23

Sim isso é possível. Você terá que criar uma instância nomeada não utilizado por outra versão do SQL Server conforme a resposta anterior e a versão 3.5 do .NET instalado. Funciona bem!!

Aqui a lista de pré-requisitos:

  • Framework 3.5 SP1
  • Windows Installer 4.5
  • Windows PowerShell 1.0
Respondeu 07/08/2008 em 10:30
fonte usuário

votos
3

Se você tiver Visual Studio 2008 instalado, você receberá um erro de validação e você não pode instalar o servidor SQL 2008 até a instalação do Visual Studio 2008 SP1. Se você não tem Visual Studio 2008 instalado, ele não deve ser um problema. Então, se você tem Visual Studio 2008 esperar até 11 de agosto, uma vez que é o dia que o Visual Studio 2008 SP1 será lançado

Respondeu 08/08/2008 em 14:23
fonte usuário

votos
2

Eu acredito que isso é perfeitamente possível. Atualmente, estou executando o SQL Server 2000 e SQL Server 2005 no meu servidor de desenvolvimento, enquanto eu transferir aplicações mais.

A única coisa que você tem a fazer é criar uma nova instância que não estiver sendo usado por SQL Server 2005.

Como com qualquer coisa nova, provavelmente haverá alguns erros, no entanto, ele geralmente deve "simplesmente funciona".

Respondeu 07/08/2008 em 09:57
fonte usuário

votos
1

Você pode executar apenas SQL 2008 como a única instância e, em seguida, anexar / criar bancos de dados com nível de compatibilidade de 2005? O problema com isso é que a sua teoria. Im não é 100% positivo que se você criar um banco de dados em 2008, com um nível de compatibilidade de 2005 e, em seguida, retirá-la, que uma instância do SQL 2005 é capaz de montar.

Eu acho que é uma chance boa o suficiente para tentar embora. Mas eu concordo com as respostas anteriores, as múltiplas opções de instância irá funcionar bem.

Respondeu 13/07/2009 em 20:07
fonte usuário

votos
1

minha experiência é depois de ter SQL Sever 2005 e 2008 na mesma SSIS máquina de 2005 não funcionar corretamente ... especialmente com tarefa de script, o fluxo de dados e recipiente seqüência

Respondeu 13/05/2009 em 09:42
fonte usuário

votos
0

Eu tenho experimentá-lo com resultado Negativo. A instalação 2K8 rompe com uma misteriosa de mensagem de erro. A instalação do protocolo parece bem, mas isso não vai funcionar. Depois disso, a instalação 2K5 foi de buggy também. A instalação 2K8 estava meio pronto, por isso é já em controlpane / software, mas desinstalação não é possível.

Então, o meu resultado - não fazê-lo em uma produtiva servidor / workstation. Se você precisa de ambas as versões, use uma máquina virtual em seu lugar.

Respondeu 03/08/2009 em 11:59
fonte usuário

votos
0

Infelizmente, parece que 2008 ferramentas de cliente SQL Server requer o Visual Studio 2008 SP1, e eu estou relutante em instalar um beta deste na minha máquina de desenvolvimento principal.

Vou esperar até SP1 é RTM antes de eu seguir em frente.

Editar : Sim, eu tenho Visual Studio 2008 nesta máquina, mas eu gostaria de evitar instalações beta de aplicativos do depurador. Eles tendem a cavar-se muito profundo no para o meu gosto.

Respondeu 08/08/2008 em 13:57
fonte usuário

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more